Members: 182  ?  Posts: 8607  ?  Topics: 739  ?  Please welcome -SyN-, our newest member.
Please login or register.

Login with username, password and session length
 

News:

Welcome To Graphics Mayhem

collapse

Author Topic: Help with Themes, etc.  (Read 343 times)

0 Members and 1 Guest are viewing this topic.

SoLoGHoST

  • SoLoGHoSt
  • Connoisseur
  • Offline
  • Posts: 1688
  • SMF MOD Expert!
  • OS:
  • Windows Vista/Server 2008
  • Browser:
  • MS Internet Explorer 8.0
Re: Help with Themes, etc.
« Reply #30 on: July 31, 2009, 02:58:57 PM »
    The files you gave me indicate you are running SMF 2.0 RC1-1 or SMF 2.0 RC 1.2.  Are you sure you are having problems from the files I gave you, as all I did was the simple edits and re-upped with those simple edits.  If you want you can reverse those edits back to the original (and yes, I know you have other MODs that affect Display.php and Display.template.php).

    Also, if you installed MODS after you gave me Display.php and Display.template.php, these MODS could've affected these files and once you overwritten these files, this is why you are getting errors since the MOD(s) that you installed are looking for the code to execute in either Display.php and/or Display.template.php.

    So if you want to uninstall the changes I made to these files, thus uninstalling this altogether...

    HOW TO UNINSTALL MANUALLY

    in Display.php
    FIND AND DELETE:
    Code: [Select]
    $context['prev_topic_page'] = empty($context['start']) ? '' : '';
    $context['next_topic_page'] = $context['total_visible_posts'] <= ($context['start'] + $context['messages_per_page']) ? '' : ' ';

    in Display.template.php
    FIND (will be found 2 times)
    Code: [Select]
    , $context['prev_topic_page'], ' ', $context['page_index'], ' ', $context['next_topic_page'],
    REPLACE WITH:
    Code: [Select]
    , $context['page_index'],
    As this was all of the edits that were changed in the files you gave me.
    « Last Edit: August 02, 2009, 01:42:27 AM by SoLoGHoST »

    plusev

    • Proficient
    • Offline
    • Posts: 116
    • OS:
    • Windows XP
    • Browser:
    • MS Internet Explorer 7.0
    Re: Help with Themes, etc.
    « Reply #31 on: July 31, 2009, 04:08:10 PM »
      I'm at a loss. Uploading the 2 files was the last thing I did. There were 2 zips in your post - maybe I downloaded the wrong one?

      +EV
      « Last Edit: July 31, 2009, 04:17:06 PM by plusev »

      SoLoGHoST

      • SoLoGHoSt
      • Connoisseur
      • Offline
      • Posts: 1688
      • SMF MOD Expert!
      • OS:
      • Windows Vista/Server 2008
      • Browser:
      • MS Internet Explorer 8.0
      Re: Help with Themes, etc.
      « Reply #32 on: July 31, 2009, 07:18:53 PM »
        Ok, I don't know what you downloaded, but just so there isn't any confusion, I'm going to remove the one's you shouldn't be downloading right now in this topic, so that the only post from me that has any attachments in it will be the 1 you need to download.  Here is a DIRECT LINK => http://graphicsmayhem.com/GMForum/index.php?action=dlattach;topic=785.0;attach=4925

        Filename is called files4plusev.zip

        Included within the .zip file are 2 files Display.php and Display.template.php

        These are the files you need to overwrite on your server in the place where they belong.  If you don't know where these files belong, let me know.  Otherwise, that's all there is to it.

        SoLoGHoST

        • SoLoGHoSt
        • Connoisseur
        • Offline
        • Posts: 1688
        • SMF MOD Expert!
        • OS:
        • Windows Vista/Server 2008
        • Browser:
        • MS Internet Explorer 7.0
        Re: Help with Themes, etc.
        « Reply #33 on: August 01, 2009, 12:43:12 PM »
          Hello, can you get back with me on this??

          Thanks :)

          plusev

          • Proficient
          • Offline
          • Posts: 116
          • OS:
          • Windows XP
          • Browser:
          • MS Internet Explorer 7.0
          Re: Help with Themes, etc.
          « Reply #34 on: August 01, 2009, 08:22:58 PM »
            Sorry solo - up to my neck in a few things. I started too many projects at once last week. I'll attempt again shortly and get backto you

            +EV

            SoLoGHoST

            • SoLoGHoSt
            • Connoisseur
            • Offline
            • Posts: 1688
            • SMF MOD Expert!
            • OS:
            • Windows Vista/Server 2008
            • Browser:
            • MS Internet Explorer 8.0
            Re: Help with Themes, etc.
            « Reply #35 on: August 01, 2009, 09:34:42 PM »
              Okie Dokie, no probs.  Maybe a better idea to uninstall manually and install via the Next Topic Page MOD that I have in the Downloads area.

              plusev

              • Proficient
              • Offline
              • Posts: 116
              • OS:
              • Windows XP
              • Browser:
              • MS Internet Explorer 7.0
              Re: Help with Themes, etc.
              « Reply #36 on: August 02, 2009, 12:37:54 PM »
                Tried it again and the same thing - the 2 files reverted everything back to how it was before edits.

                I'm kinda paranoid about uninstalling maually. I have edits from both you and shorty and don't want to jack anything up.

                Could you double check my files that I re-uploaded on friday with the ones you edited for download? Thx

                The other thing I noticed is that the right side prev/next go to the bottom post of the prev/next topic instead of the top.
                « Last Edit: August 02, 2009, 12:43:44 PM by plusev »

                SoLoGHoST

                • SoLoGHoSt
                • Connoisseur
                • Offline
                • Posts: 1688
                • SMF MOD Expert!
                • OS:
                • Windows Vista/Server 2008
                • Browser:
                • MS Internet Explorer 8.0
                Re: Help with Themes, etc.
                « Reply #37 on: August 02, 2009, 06:21:11 PM »
                  Hello, can you please upload your Display.php and Display.template.php files and PLEASE let us know what error message you are getting as I don't wanna accidentally grab the wrong files, edit them and give them back to you.  Please just respond with the files attached and all error messages you get, if any.  Or any problems you get also.

                  Thanks :)

                  plusev

                  • Proficient
                  • Offline
                  • Posts: 116
                  • OS:
                  • Windows XP
                  • Browser:
                  • MS Internet Explorer 7.0
                  Re: Help with Themes, etc.
                  « Reply #38 on: August 06, 2009, 01:13:33 PM »
                    Hey Solo,

                    Things are back on track and back to work on my forum. Here is a link to the forum after the edits you gave me are installed. After you have a look I'll install the older files and you can see how it was (almost) working. Also notice that besides it not functioning the right side topic prev/next jumps down to the last post of the next topic not the first as is normal. BTW, there is no error message.

                    Thx, +EV

                    http://www.positiveexpectedvalue.com/general-poker-discussion/test/

                    SoLoGHoST

                    • SoLoGHoSt
                    • Connoisseur
                    • Offline
                    • Posts: 1688
                    • SMF MOD Expert!
                    • OS:
                    • Windows Vista/Server 2008
                    • Browser:
                    • MS Internet Explorer 8.0
                    Re: Help with Themes, etc.
                    « Reply #39 on: August 06, 2009, 04:02:51 PM »
                      Ok, will take a look at it soon, but all you have to do is get rid of the #new from the end of the link for both Previous and Next topic links on the right top and right bottom.  Also, looks like you are missing the prev.png and next.png images that should be located in your default themes images directory.
                       


                      Search


                      Latest Activity.
                      September's Logo Challenge "Up Top" (2009)... by NerdBoy
                      [Today at 11:32:59 AM]


                      Loop through posts from any given Board at a Set Interval by SoLoGHoST
                      [Today at 10:30:26 AM]


                      Pixel Perfect For SMF 2.x RC1.2 by Shortie
                      [Today at 08:38:57 AM]


                      A Genie by MJCSD
                      [Yesterday at 11:31:35 PM]


                      Want to start a topic here? by SoLoGHoST
                      [Yesterday at 10:49:57 PM]


                      PM Attachments - SMF MOD of the MONTH by SoLoGHoST
                      [Yesterday at 06:09:09 PM]


                      Graphics Mayhem Wallpaper Collection September 2009 by Shortie
                      [Yesterday at 04:29:07 PM]


                      Help with header area and logo? by Shortie
                      [Yesterday at 02:22:43 PM]


                      Theme Bugs and Display Issues by Shortie
                      [Yesterday at 10:29:29 AM]


                      GM Wall by NerdBoy
                      [Yesterday at 09:16:31 AM]


                      Playground layout tweaks by dobie
                      [Yesterday at 05:56:31 AM]


                      Help Needed.. by Shortie
                      [Yesterday at 03:01:09 AM]


                      Solosmileys by SoLoGHoST
                      [September 07, 2009, 02:28:16 PM]


                      Graphics Association Game! by Shortie
                      [September 07, 2009, 01:33:01 AM]



                      Page created in 0.089 seconds with 20 queries.