Members: 475  •  Posts: 18778  •  Topics: 1157  •  Please welcome Mai, our newest member.
Please login or register.

Login with username, password and session length
 

News:

Welcome To Graphics Mayhem


collapse

Author Topic: Help with Playroom theme  (Read 86 times)

0 Members and 1 Guest are viewing this topic.

Kimmie

  • Apprentice
  • Posts: 12
  • OS:
  • Windows 7
  • Browser:
  • Opera 10.00
Help with Playroom theme
« on: May 02, 2010, 04:37:01 PM »
Hi :)

I just installed the playroom theme.  I used to use the Playground Theme Set so I was able to get some of this done myself, but I am needing a little help with buttons and some code for a mod I have installed :)

I got the code put back in for the TAGS mod and I am having it use the rules.png image for that. The problem is, when you hover over that button it doesnt display the word "tags" under it so that folks know what its for.

2nd question, I am using the Automatic Index mod found here:

Code: [Select]
http://custom.simplemachines.org/mods/index.php?mod=1970
Could you help me with that code and an image as well?  please please please  hehehe. When the button installs in the default theme its caption is "Automatic Index" but I feel thats too long of a phrase. Could you have it just show up as "Index" when you hover over the button?


My members as well as myself THANK you for all your hard work on these theme sets. I know alot of work goes into them and it is GREATLY appreciated!!! :)

Shortie

  • Administrator
  • Authority
  • Posts: 5215
  • The Ultimate Boss
  • OS:
  • Windows 7
  • Browser:
  • Firefox 3.6.3
Re: Help with Playroom theme
« Reply #1 on: May 02, 2010, 05:16:56 PM »
Hi Ya Kimmie

Will pick this up tomorrow UK time

There is a little frigg to do But I will work out a nice way to do it so it will be beneficial to you

Shortie

Thank You, "Guest" For Reading My Post.


Kimmie

  • Apprentice
  • Posts: 12
  • OS:
  • Windows 7
  • Browser:
  • Opera 10.00
Re: Help with Playroom theme
« Reply #2 on: May 02, 2010, 05:32:53 PM »
awesome!! :)

I dont know what a frigg is, will it hurt?  lol


look forward to hearing back from you tomorrow.

Brack

  • Practiced
  • Posts: 68
  • Boldly Going Nowhere
  • OS:
  • Windows XP
  • Browser:
  • Firefox 3.6.3
Re: Help with Playroom theme
« Reply #3 on: May 02, 2010, 05:43:00 PM »
By frigg I would assume Shortie is talking about a little tweak which is required.

 :D

Nukegaming

  • Accomplished
  • Posts: 466
  • OS:
  • Windows Vista
  • Browser:
  • Firefox 3.6.3
Re: Help with Playroom theme
« Reply #4 on: Yesterday at 02:17:32 AM »
and what is this mod do basicaly can anyone explain.

if it is any good i might try to install at my main website.

i realy hope it is a worth mod but i only got like 20 mods instaled on my site and maybe i need more who knows.


MY MODS

Shortie

  • Administrator
  • Authority
  • Posts: 5215
  • The Ultimate Boss
  • OS:
  • Windows 7
  • Browser:
  • Firefox 3.6.3
Re: Help with Playroom theme
« Reply #5 on: Yesterday at 03:32:55 AM »
Okay first one first

In the themes

Languages folder find ThemeStrings.english.php

And add the following changing the description to what is required

Code: [Select]
$txt['gmtags'] = 'Your Descrition here';

Now in the index.template.php

Find the link for the button and change the alt element from

Code: [Select]
alt="' . $txt['gmrules'] .'" />' . $txt['gmrules'], '';

TO

Code: [Select]
alt="' . $txt['gmtags'] .'" />' . $txt['gmtags'], '';

NOTE as you have changed the language setting you will need to Flush the cache

Now the second one

The above will be required for the Index Button but should be straight forward to complete

To change the title for all the other themes

find

/Themes/default/languages/Modifications.english.php

And look for the section relating to the mod

and change the relevant lines e.g.

Find

Code: [Select]
$txt['auto_index_menu_button'] = 'Automatic Index';

and change to

Code: [Select]
$txt['auto_index_menu_button'] = 'This will be your title here';

Any problems give me a shout

Oh the line to control the button is as follows

Code: [Select]
if (empty($modSettings['auto_index_invitados']) ? !$user_info['is_guest'] : $user_info['is_guest'] || !$user_info['is_guest']) && !empty($modSettings['auto_index_active']))
echo '' . $txt['gmautoindex'] .'' . $txt['gmautoindex'], '';

NOTE This may need a little adjustment so backup you Index.template.php before the edit

Shortie

Thank You, "Guest" For Reading My Post.


Kimmie

  • Apprentice
  • Posts: 12
  • OS:
  • Windows 7
  • Browser:
  • Opera 10.00
Re: Help with Playroom theme
« Reply #6 on: Yesterday at 08:02:26 PM »
ok I will get these edits made shortly, I have another issue I am currently dealing with that I think might be related to this theme as well. The errors I am seeing only happen when using this theme:

Here is one but there are several as they happen with just about every page view:

8: Undefined index: gmtags

File: /home/*****/public_html/Themes/default/GenericMenu.template.php (body_above sub template - eval?)
Line: 669


Not sure exactly yet where the problem is.  Each one refers to something called "gmtags" and I have no clue where that is stemming from..lol.

A few more are
File: /home/****/public_html/Themes/default/Recent.template.php (body_above sub template - eval?
File: /home/****/public_html/Themes/default/Login.template.php (body_above sub template - eval?



EDIT: I think I know what the problem is. In my original post here, if you recall, I stated that I had already inserted the code for my tags mod. What I did was simply copy and paste the code I used for it from the playground theme into the index file on this theme. And I dont think they are the same..lol. Here is the code I put in for the tags mod:

Code: [Select]
     ' . $txt['gmtags'] . '' . $txt['gmtags'] . ' ';

I will work on seeing if I can get it figured out but if you happen to spot whats wrong with it, feel free to post here and let me know as well..hehehe. I think I might just need to let you look at my index.template.php file I dont wanna screw it up even more..lol. Since I cant post it as an attachment, I can either post it all in a post or I can upload it for you somewhere. Just let me know. :)
« Last Edit: Yesterday at 08:26:42 PM by Kimmie »

Shortie

  • Administrator
  • Authority
  • Posts: 5215
  • The Ultimate Boss
  • OS:
  • Windows 7
  • Browser:
  • Firefox 3.6.3
Re: Help with Playroom theme
« Reply #7 on: Today at 01:31:21 AM »
Check

The themes

/languages/ThemeStrings.english.php

and make sure gmtags is defined and then flush your cache

Thank You, "Guest" For Reading My Post.


 


Search



Latest Activity.

Help with Playroom theme by Shortie
[Today at 01:31:21 AM]


Logo Assistance by MATTEK
[Yesterday at 08:46:44 PM]


Need some input by Shortie
[May 02, 2010, 01:08:37 PM]


Membergroup Images by Shortie
[May 02, 2010, 08:03:17 AM]


General Wallpapers by Shortie
[May 02, 2010, 04:35:09 AM]


May 2010 'Uptop' Logo Contest by Shortie
[May 02, 2010, 04:31:27 AM]


Need a new Icon by Shortie
[May 02, 2010, 03:45:25 AM]


The PlayGround Ultimate Support Thread by Shortie
[May 02, 2010, 03:29:40 AM]


Try Photoshop CS5 Now! by Nukegaming
[May 01, 2010, 03:47:10 AM]


April 2010 'Uptop' Logo Contest by DMHolt57
[April 30, 2010, 10:43:47 PM]


Alpha Testers required by Shortie
[April 30, 2010, 05:30:09 PM]


What is the difference between Illustrator and photoshop? by Nukegaming
[April 30, 2010, 11:15:28 AM]


May Mayhem Make Over by lc62003
[April 29, 2010, 09:37:26 PM]


Get Known GM by NerdBoy
[April 29, 2010, 02:15:06 PM]


Help with my sites look by kingkingston
[April 29, 2010, 09:45:58 AM]